Error when inserting a driver into boot images (WIM file)

Issue: Sometimes you happen to import network drivers in boot image file and you receive this below error , even if you try to update DPs manually.

Error: Failed to import the following drivers:
Intel® 82567LM-3 Gigabit Network Connection - Failed to inject a ConfigMgr driver into the mounted WIM file

Error: The wizard detected the following problems when updating the boot image.
Failed to inject a ConfigMgr driver into the mounted WIM file
Failed to inject a ConfigMgr driver into the mounted WIM file
Failed to inject a ConfigMgr driver into the mounted WIM file
Failed to inject a ConfigMgr driver into the mounted WIM file
The ConfigMgr Provider reported an error.: ConfigMgr Error Object:
instance of SMS_ExtendedStatus
{
Description = "Failed to insert OSD binaries into the WIM file";
ErrorCode = 2152205056;
File = "c:\\qfe\\nts_sms_fre\\sms\\siteserver\\sdk_provider\\smsprov\\sspbootimagepackage.cpp";
Line = 4262;
ObjectInfo = "CSspBootImagePackage::PreRefreshPkgSrcHook";
Operation = "ExecMethod";
ParameterInfo = "SMS_BootImagePackage.PackageID=\"BWW00015\"";
ProviderName = "WinMgmt";
StatusCode = 2147749889;
};


Solution
Method 1: Try deleting "PXEBootFiles" from C:\Windows\temp"
Method 2:  Checked the logs C:\Windows\Logs\DISM\dism.log and found 
Warning DISM   DISM Provider Store: PID=8140 Failed to Load the provider: C:\WINDOWS\TEMP\CDFB3C58-4DF0-4F57-B180-A3E77EB8E589\TransmogProvider.dll. - CDISMProviderStore::Internal_GetProvider(hr:0x8007007e)

Bear in mind it uses the C:\Windows\Temp folder of the server to stage, mount and inject the drivers.So i found there were lot of folder created Under C:\windows\temp\Bootimages . I deleted them one by one and also Clened up Temp folder and tried importing drivers again and updating DPS' and it worked fine.

Reference:
1.  http://blogs.technet.com/b/configurationmgr/archive/2010/06/17/solution-you-may-be-unable-to-import-boot-images-manually-or-through-configmgr-2007-admin-console.aspx
2. http://www.systemcentercentral.com/forums-archive/topic/error-when-inserting-a-driver-into-boot-images-wim-file/
3. http://www.windows-noob.com/forums/index.php?/topic/4495-injecting-drivers-for-boot-image/

Comments

  1. I have a similar issue. What do you do if you don't know what was deleted?

    Delete all drivers and start over?

    ReplyDelete

Post a Comment

Popular posts from this blog

The install4j wizard could not find a Java Runtime Environment on your system. Please locate a suitable JRE...

Clients Unable to update - "Cached cookie has expired or new PID is available"

Java Control Panel Icon "Application Not Found"